using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\$\n^\s+";
string input = @"add add-default-route=yes comment=""WAN ROSTELECOM"" disabled=no interface=\
ether1 keepalive-timeout=disabled name=pppoe-wan1-rostel password=\
313131231 use-peer-dns=yes user=21412431241";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}