#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)"
Local $sString = "фывфыв</div><br></div>фывфыв<div><br></div>" & @CRLF & _
"фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>" & @CRLF & _
"" & @CRLF & _
"Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")