$re = '/(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)/m';
$str = 'фывфыв</div><br></div>фывфыв<div><br></div>
фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>
Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);