using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)";
string input = @"фывфыв</div><br></div>фывфыв<div><br></div>
фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>
Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}