use strict;
my $str = 'фывфыв</div><br></div>фывфыв<div><br></div>
фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>
Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и';
my $regex = qr/(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}