re = /(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)/m
str = 'фывфыв</div><br></div>фывфыв<div><br></div>
фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>
Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end