import re
regex = re.compile(r"(?=(<\/?div><br><\/div>))(?!(<div><br><\/div>)$)", flags=re.MULTILINE)
test_str = ("фывфыв</div><br></div>фывфыв<div><br></div>\n"
"фывфыв<div><div><div><br></div><br></div><br></div>.фывфыв<div><br></div>\n\n"
"Как через регулярные выражения можно удалять такие теги (div и br), при чем только в конце строки, т.к. конструкция <div><br></div> - это перенос на новую строку между двумя абзацами, и")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")