#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.{5,10}$)[a-z][a-z]*\d[a-z\d]*$"
Local $sString = "// Good" & @CRLF & _
"ABCABCABC1" & @CRLF & _
"ABCA1BCAB" & @CRLF & _
"A1BCABCA" & @CRLF & _
"A1BCAB" & @CRLF & _
"A1BCA" & @CRLF & _
"" & @CRLF & _
"// BAD" & @CRLF & _
"A1BC" & @CRLF & _
"1BCABCABC1" & @CRLF & _
"ABCABCABC12" & @CRLF & _
"ABCABCABCD" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")