re = /^(?=.{5,10}$)[a-z][a-z]*\d[a-z\d]*$/mi
str = '// Good
ABCABCABC1
ABCA1BCAB
A1BCABCA
A1BCAB
A1BCA
// BAD
A1BC
1BCABCABC1
ABCABCABC12
ABCABCABCD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end