const regex = /^(?=.{5,10}$)[a-z][a-z]*\d[a-z\d]*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{5,10}$)[a-z][a-z]*\\d[a-z\\d]*$', 'gmi')
const str = `// Good
ABCABCABC1
ABCA1BCAB
A1BCABCA
A1BCAB
A1BCA
// BAD
A1BC
1BCABCABC1
ABCABCABC12
ABCABCABCD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}