use strict;
my $str = '// Good
ABCABCABC1
ABCA1BCAB
A1BCABCA
A1BCAB
A1BCA
// BAD
A1BC
1BCABCABC1
ABCABCABC12
ABCABCABCD
';
my $regex = qr/^(?=.{5,10}$)[a-z][a-z]*\d[a-z\d]*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}