$re = '/^(?=.{5,10}$)[a-z][a-z]*\d[a-z\d]*$/mi';
$str = '// Good
ABCABCABC1
ABCA1BCAB
A1BCABCA
A1BCAB
A1BCA
// BAD
A1BC
1BCABCABC1
ABCABCABC12
ABCABCABCD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);