import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{5,10}$)[a-z][a-z]*\\d[a-z\\d]*$";
final String string = "// Good\n"
+ "ABCABCABC1\n"
+ "ABCA1BCAB\n"
+ "A1BCABCA\n"
+ "A1BCAB\n"
+ "A1BCA\n\n"
+ "// BAD\n"
+ "A1BC\n"
+ "1BCABCABC1\n"
+ "ABCABCABC12\n"
+ "ABCABCABCD\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}