using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\w:\\|\\{1,2})((\.{2}\\)+|(\.+\\)?).+";
string input = @"..\meeting_minutes.txt
..\..\profile.txt
Reports\2023\summary.txt
\Reports\2023\summary.txt
C:\my_file.txt
\\Reports\2023\summary.txt
.\Reports\2023\summary.txt
..\Projects\project_a.docx
..\Projects\project a.docx
.\my_file.txt
.\my file.txt
..\..\data
..\Music#a\file.mp3
..\Music[Genre]\file.mp3
..\Music(Genre)\file.mp3
..\Music-Hardcore-Metal\file.mp3
..\Documents\My+File.xlsx
..\Documents\Some{Document}.py
..\Files\Afilewithweird;Characters'`.doc
..\Music#^@!()-+{};',.`~a\file.mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}