import Foundation
let pattern = #"^(?!\w:\\|\\{1,2})((\.{2}\\)+|(\.+\\)?).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
..\meeting_minutes.txt
..\..\profile.txt
Reports\2023\summary.txt
\Reports\2023\summary.txt
C:\my_file.txt
\\Reports\2023\summary.txt
.\Reports\2023\summary.txt
..\Projects\project_a.docx
..\Projects\project a.docx
.\my_file.txt
.\my file.txt
..\..\data
..\Music#a\file.mp3
..\Music[Genre]\file.mp3
..\Music(Genre)\file.mp3
..\Music-Hardcore-Metal\file.mp3
..\Documents\My+File.xlsx
..\Documents\Some{Document}.py
..\Files\Afilewithweird;Characters'`.doc
..\Music#^@!()-+{};',.`~a\file.mp3
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)