import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\w:\\\\|\\\\{1,2})((\\.{2}\\\\)+|(\\.+\\\\)?).+";
final String string = "..\\meeting_minutes.txt\n"
+ "..\\..\\profile.txt\n"
+ "Reports\\2023\\summary.txt\n"
+ "\\Reports\\2023\\summary.txt\n"
+ "C:\\my_file.txt\n"
+ "\\\\Reports\\2023\\summary.txt\n"
+ ".\\Reports\\2023\\summary.txt\n"
+ "..\\Projects\\project_a.docx\n"
+ "..\\Projects\\project a.docx\n"
+ ".\\my_file.txt\n"
+ ".\\my file.txt\n"
+ "..\\..\\data\n"
+ "..\\Music#a\\file.mp3\n"
+ "..\\Music[Genre]\\file.mp3\n"
+ "..\\Music(Genre)\\file.mp3\n"
+ "..\\Music-Hardcore-Metal\\file.mp3\n"
+ "..\\Documents\\My+File.xlsx\n"
+ "..\\Documents\\Some{Document}.py\n"
+ "..\\Files\\Afilewithweird;Characters'`.doc\n"
+ "..\\Music#^@!()-+{};',.`~a\\file.mp3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}