import re
regex = re.compile(r"^(?!\w:\\|\\{1,2})((\.{2}\\)+|(\.+\\)?).+", flags=re.MULTILINE)
test_str = ("..\\meeting_minutes.txt\n"
"..\\..\\profile.txt\n"
"Reports\\2023\\summary.txt\n"
"\\Reports\\2023\\summary.txt\n"
"C:\\my_file.txt\n"
"\\\\Reports\\2023\\summary.txt\n"
".\\Reports\\2023\\summary.txt\n"
"..\\Projects\\project_a.docx\n"
"..\\Projects\\project a.docx\n"
".\\my_file.txt\n"
".\\my file.txt\n"
"..\\..\\data\n"
"..\\Music#a\\file.mp3\n"
"..\\Music[Genre]\\file.mp3\n"
"..\\Music(Genre)\\file.mp3\n"
"..\\Music-Hardcore-Metal\\file.mp3\n"
"..\\Documents\\My+File.xlsx\n"
"..\\Documents\\Some{Document}.py\n"
"..\\Files\\Afilewithweird;Characters'`.doc\n"
"..\\Music#^@!()-+{};',.`~a\\file.mp3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")