use strict;
my $str = '..\\meeting_minutes.txt
..\\..\\profile.txt
Reports\\2023\\summary.txt
\\Reports\\2023\\summary.txt
C:\\my_file.txt
\\\\Reports\\2023\\summary.txt
.\\Reports\\2023\\summary.txt
..\\Projects\\project_a.docx
..\\Projects\\project a.docx
.\\my_file.txt
.\\my file.txt
..\\..\\data
..\\Music#a\\file.mp3
..\\Music[Genre]\\file.mp3
..\\Music(Genre)\\file.mp3
..\\Music-Hardcore-Metal\\file.mp3
..\\Documents\\My+File.xlsx
..\\Documents\\Some{Document}.py
..\\Files\\Afilewithweird;Characters\'`.doc
..\\Music#^@!()-+{};\',.`~a\\file.mp3';
my $regex = qr/^(?!\w:\\|\\{1,2})((\.{2}\\)+|(\.+\\)?).+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}