#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!!)(.*[\u4e00-\u9fff]+.*)"
Local $sString = "!asdf" & @CRLF & _
"asdf" & @CRLF & _
"中國" & @CRLF & _
"ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ" & @CRLF & _
"中國 ㅁㄴㅇㄹ 中國" & @CRLF & _
"! ㅁㄴㅇㄹ 中國" & @CRLF & _
"!中國"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")