import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!!)(.*[\\u4e00-\\u9fff]+.*)";
final String string = "!asdf\n"
+ "asdf\n"
+ "中國\n"
+ "ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ\n"
+ "中國 ㅁㄴㅇㄹ 中國\n"
+ "! ㅁㄴㅇㄹ 中國\n"
+ "!中國";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}