re = /^(?!!)(.*[\u4e00-\u9fff]+.*)/m
str = '!asdf
asdf
中國
ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ
中國 ㅁㄴㅇㄹ 中國
! ㅁㄴㅇㄹ 中國
!中國'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end