using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!!)(.*[\u4e00-\u9fff]+.*)";
string input = @"!asdf
asdf
中國
ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ
中國 ㅁㄴㅇㄹ 中國
! ㅁㄴㅇㄹ 中國
!中國";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}