const regex = new RegExp('^(?!!)(.*[\\u4e00-\\u9fff]+.*)', 'gm')
const str = `!asdf
asdf
中國
ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ
中國 ㅁㄴㅇㄹ 中國
! ㅁㄴㅇㄹ 中國
!中國`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}