$re = '/^(?!!)(.*[\u4e00-\u9fff]+.*)/m';
$str = '!asdf
asdf
中國
ㅁㄴㅇㄹ 中國 ㅁㄴㅇㄹ
中國 ㅁㄴㅇㄹ 中國
! ㅁㄴㅇㄹ 中國
!中國';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);