import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}(\\-[a-zA-Z]{1,50})?)";
final String string = "Should match\n"
+ "0.0.0\n"
+ "0.0.0-a\n"
+ "1.5.89-lorem\n"
+ "6.12.5-iPsUm\n\n"
+ "Mustn't match (even partially)\n"
+ "a.2.3 -> 'a' is not a number\n"
+ "1.5.89:lorem -> only '-' is valid to separate version and letters\n"
+ "1.2.3-4 -> '4' is not letter(s)\n"
+ "5.6.8.9 -> '9' is not letters and '.' used instead of '-'\n"
+ "8.k.2-j -> 'k' is not a number\n"
+ "7895.5.8 -> '7895' is 4 digit long, 3 is the max\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}