# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(\-[a-zA-Z]{1,50})?)"
test_str = ("Should match\n"
"0.0.0\n"
"0.0.0-a\n"
"1.5.89-lorem\n"
"6.12.5-iPsUm\n\n"
"Mustn't match (even partially)\n"
"a.2.3 -> 'a' is not a number\n"
"1.5.89:lorem -> only '-' is valid to separate version and letters\n"
"1.2.3-4 -> '4' is not letter(s)\n"
"5.6.8.9 -> '9' is not letters and '.' used instead of '-'\n"
"8.k.2-j -> 'k' is not a number\n"
"7895.5.8 -> '7895' is 4 digit long, 3 is the max\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.