import Foundation
let pattern = #"([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(\-[a-zA-Z]{1,50})?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match
0.0.0
0.0.0-a
1.5.89-lorem
6.12.5-iPsUm
Mustn't match (even partially)
a.2.3 -> 'a' is not a number
1.5.89:lorem -> only '-' is valid to separate version and letters
1.2.3-4 -> '4' is not letter(s)
5.6.8.9 -> '9' is not letters and '.' used instead of '-'
8.k.2-j -> 'k' is not a number
7895.5.8 -> '7895' is 4 digit long, 3 is the max
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)