const regex = /([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(\-[a-zA-Z]{1,50})?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}(\\-[a-zA-Z]{1,50})?)', 'gm')
const str = `Should match
0.0.0
0.0.0-a
1.5.89-lorem
6.12.5-iPsUm
Mustn't match (even partially)
a.2.3 -> 'a' is not a number
1.5.89:lorem -> only '-' is valid to separate version and letters
1.2.3-4 -> '4' is not letter(s)
5.6.8.9 -> '9' is not letters and '.' used instead of '-'
8.k.2-j -> 'k' is not a number
7895.5.8 -> '7895' is 4 digit long, 3 is the max
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}