use strict;
my $str = 'Should match
0.0.0
0.0.0-a
1.5.89-lorem
6.12.5-iPsUm
Mustn\'t match (even partially)
a.2.3 -> \'a\' is not a number
1.5.89:lorem -> only \'-\' is valid to separate version and letters
1.2.3-4 -> \'4\' is not letter(s)
5.6.8.9 -> \'9\' is not letters and \'.\' used instead of \'-\'
8.k.2-j -> \'k\' is not a number
7895.5.8 -> \'7895\' is 4 digit long, 3 is the max
';
my $regex = qr/([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}(\-[a-zA-Z]{1,50})?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}