#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?.*?(\w{4,})(?=(?:\.\w{2,3})+\/)"
Local $sString = "let str = 'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico'" & @CRLF & _
"let str1 = 'https://www.google.com/images/branding/product/ico/googleg_lodp.ico'" & @CRLF & _
"let str2 = 'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico'" & @CRLF & _
"http://test.google.com/test.google.com/" & @CRLF & _
"http://a.b.c.d.test.google.com/test.google.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")