using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?.*?(\w{4,})(?=(?:\.\w{2,3})+\/)";
string input = @"let str = 'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico'
let str1 = 'https://www.google.com/images/branding/product/ico/googleg_lodp.ico'
let str2 = 'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico'
http://test.google.com/test.google.com/
http://a.b.c.d.test.google.com/test.google.com/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}