import Foundation
let pattern = #"https?.*?(\w{4,})(?=(?:\.\w{2,3})+\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
let str = 'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico'
let str1 = 'https://www.google.com/images/branding/product/ico/googleg_lodp.ico'
let str2 = 'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico'
http://test.google.com/test.google.com/
http://a.b.c.d.test.google.com/test.google.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)