$re = '/https?.*?(\w{4,})(?=(?:\.\w{2,3})+\/)/';
$str = 'let str = \'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico\'
let str1 = \'https://www.google.com/images/branding/product/ico/googleg_lodp.ico\'
let str2 = \'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico\'
http://test.google.com/test.google.com/
http://a.b.c.d.test.google.com/test.google.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);