import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?.*?(\\w{4,})(?=(?:\\.\\w{2,3})+\\/)";
final String string = "let str = 'https://www.google.com.ua/images/branding/product/ico/googleg_lodp.ico'\n"
+ "let str1 = 'https://www.google.com/images/branding/product/ico/googleg_lodp.ico'\n"
+ "let str2 = 'https://books.google.com.ua/images/branding/product/ico/googleg_lodp.ico'\n"
+ "http://test.google.com/test.google.com/\n"
+ "http://a.b.c.d.test.google.com/test.google.com/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}