using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|""/TCH-EXP)[^""]+\K""+(?!,""|$)";
string input = @"""/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs""da.ppt"","",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,""TFR012"",""
_
""/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data (2).msg"","",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,""TFR012"",""
""/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data ""20-nov-2003"".msg"","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,""TFR012"",""
""/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data ""20-nov-2003"".msg""
""/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan ""B"" data ""20-nov-2003"".msg"","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,""TFR012"",""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}