const regex = new RegExp('(?:\\G(?!^)|"/TCH-EXP)[^"]+\\K"+(?!,"|$)', 'gm')
const str = `"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs"da.ppt","",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,"TFR012",""
_
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan "B" data (2).msg","",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg"
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}