import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|\"/TCH-EXP)[^\"]+\\K\"+(?!,\"|$)";
final String string = "\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs\"da.ppt\",\"\",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,\"TFR012\",\"\"\n"
+ "_\n"
+ "\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"B\" data (2).msg\",\"\",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"\n\n"
+ "\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\",\"\",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"\n\n\n"
+ "\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\"\n\n"
+ "\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\",\"\",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}