$re = '~(?:\G(?!^)|"/TCH-EXP)[^"]+\K"+(?!,"|$)~m';
$str = '"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs"da.ppt","",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,"TFR012",""
_
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan "B" data (2).msg","",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg"
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);