use strict;
my $str = '"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs"da.ppt","",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,"TFR012",""
_
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan "B" data (2).msg","",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan ""B"" data "20-nov-2003".msg"
"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan ""B"" data "20-nov-2003".msg","",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,"TFR012",""';
my $regex = qr~(?:\G(?!^)|"/TCH-EXP)[^"]+\K"+(?!,"|$)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}