import re
regex = re.compile(r"(?:\G(?!^)|\"/TCH-EXP)[^\"]+\K\"+(?!,\"|$)", flags=re.MULTILINE)
test_str = ("\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/PowerPoint/Privat/Emilie Føs\"da.ppt\",\"\",143872,Mon Mar 5 10:02:22 2007,Mon Mar 5 10:02:22 2007,\"TFR012\",\"\"\n"
"_\n"
"\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"B\" data (2).msg\",\"\",2092544,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"\n\n"
"\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\",\"\",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"\n\n\n"
"\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\"\n\n"
"\"/TCH-EXP/mnt/office/dept/ped/Tyra New Structure/_Personal Folders/TFR/Tfr/Siemens test, Data/Halfdan \"\"B\"\" data \"20-nov-2003\".msg\",\"\",1060864,Mon Feb 9 09:22:32 2004,Mon Feb 9 09:22:32 2004,\"TFR012\",\"\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")