#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/de).+(\/des\/car\/|\/vip\/car\/).+(\/dealer\/de\/|\/fsbo\/de\/).+(\/contact|\/contactvendor)"
Local $sString = "/details/contact" & @CRLF & _
"/de/public/des/car/used/dealer/de/details/contactvendor" & @CRLF & _
"/de/public/des/car/used/dealer/de/details/contact"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")