// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/de).+(\/des\/car\/|\/vip\/car\/).+(\/dealer\/de\/|\/fsbo\/de\/).+(\/contact|\/contactvendor)").unwrap();
let string = "/details/contact
/de/public/des/car/used/dealer/de/details/contactvendor
/de/public/des/car/used/dealer/de/details/contact";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}