package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/de).+(\/des\/car\/|\/vip\/car\/).+(\/dealer\/de\/|\/fsbo\/de\/).+(\/contact|\/contactvendor)`)
var str = `/details/contact
/de/public/des/car/used/dealer/de/details/contactvendor
/de/public/des/car/used/dealer/de/details/contact`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}