import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/de).+(\\/des\\/car\\/|\\/vip\\/car\\/).+(\\/dealer\\/de\\/|\\/fsbo\\/de\\/).+(\\/contact|\\/contactvendor)";
final String string = "/details/contact\n"
+ "/de/public/des/car/used/dealer/de/details/contactvendor\n"
+ "/de/public/des/car/used/dealer/de/details/contact";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}