$re = '/(\/de).+(\/des\/car\/|\/vip\/car\/).+(\/dealer\/de\/|\/fsbo\/de\/).+(\/contact|\/contactvendor)/m';
$str = '/details/contact
/de/public/des/car/used/dealer/de/details/contactvendor
/de/public/des/car/used/dealer/de/details/contact';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);