const regex = /(\/de).+(\/des\/car\/|\/vip\/car\/).+(\/dealer\/de\/|\/fsbo\/de\/).+(\/contact|\/contactvendor)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/de).+(\\\/des\\\/car\\\/|\\\/vip\\\/car\\\/).+(\\\/dealer\\\/de\\\/|\\\/fsbo\\\/de\\\/).+(\\\/contact|\\\/contactvendor)', 'gm')
const str = `/details/contact
/de/public/des/car/used/dealer/de/details/contactvendor
/de/public/des/car/used/dealer/de/details/contact`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}