#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z])(?=.*\d).{8,}$"
Local $sString = "JavaScript正则表达式" & @CRLF & _
"要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位" & @CRLF & _
"" & @CRLF & _
"sldkfjfl798kl" & @CRLF & _
"看来数据打分了" & @CRLF & _
"ksdfjdkf的路口附近8" & @CRLF & _
"路上的风景&*(+j8" & @CRLF & _
"jsdlfkjfdLKJLK" & @CRLF & _
"123456789" & @CRLF & _
"687678987Kh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")