import Foundation
let pattern = #"^(?=.*[a-zA-Z])(?=.*\d).{8,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
JavaScript正则表达式
要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位
sldkfjfl798kl
看来数据打分了
ksdfjdkf的路口附近8
路上的风景&*(+j8
jsdlfkjfdLKJLK
123456789
687678987Kh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)