# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*[a-zA-Z])(?=.*\d).{8,}$"
test_str = ("JavaScript正则表达式\n"
"要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位\n\n"
"sldkfjfl798kl\n"
"看来数据打分了\n"
"ksdfjdkf的路口附近8\n"
"路上的风景&*(+j8\n"
"jsdlfkjfdLKJLK\n"
"123456789\n"
"687678987Kh")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.