import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-zA-Z])(?=.*\\d).{8,}$";
final String string = "JavaScript正则表达式\n"
+ "要求:所有字符都可以输入,但是必须含有字母(不区分大小写)和数字,且总长度不低于8位\n\n"
+ "sldkfjfl798kl\n"
+ "看来数据打分了\n"
+ "ksdfjdkf的路口附近8\n"
+ "路上的风景&*(+j8\n"
+ "jsdlfkjfdLKJLK\n"
+ "123456789\n"
+ "687678987Kh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}